Reports - Intro Notes - Back to Index

iBook Logic Board Failure


I am happy to say that I have got my iBook back and it seems to be working fine. I was however a bit concerned by the fact that there were no passwords on any of my accounts! At Apple's request I had provided them with one username and password which I assumed they wanted for testing, but for some reason they saw fit to reset it to a null one (just hit "return"). Not only that, but they had set a null password for my main account and for the root account! For the ordinary accounts I just put passwords back on, but for the root account it was more complicated because they had set it in such a way as to break the "Security" menu in NetInfo Manager. Fortunately I found an easy fix documented here, which just required running niutil(1) to reset the passwd field for root back to the default locked value.


On Monday evening I closed the lid of my iBook, putting it to sleep as I often do. When I opened it a couple of hours later the pulsing white "sleep light" went out but the screen remained resolutely blank. Houston we have a problem! What follows is a description of my efforts to recover from this tricky situation.

I knew that the machine had woken up because I could hear the disk whirring away quietly. The fact that I could eject the CD tray and hear audible feedback when pressing the volume keys led me to believe that it was just a display problem. I held down the power button till the machine shut down (something I am normally loath to do) and when I started it up again I heard the chime but the screen was still blank. I then closed the lid and noticed that it did not go to sleep (no sleep light and disk still spinning). I also tried connecting an external monitor and restarting again but got "no signal". The next logical step was to try to get in remotely (fortunately I had enabled ssh) but I was at home and the machine was still set to my "work" location with a static IP address on Ethernet, and the wrong SSID for my home wireless network. I decided to give up for the night.

In the morning I got up early and went to work armed with iBook and the FireWire drive containing a somewhat recent backup made with Carbon Copy Cloner (CCC). I plugged in an Ethernet cable and much to my relief I was able to connect using ssh from my Solaris box. Apart from the blank display everything seemed fine. I wanted to get a fresh backup but CCC is a GUI application. No problem, I was only really concerned with getting my home directory backed up so I decided to use the Mac OS X command line utility called "ditto". I plugged in the FireWire drive and heard it spin up but nothing got mounted - it seems that you need to be logged in to the GUI for that to happen automatically! Oh well, I manually mounted the FireWire partitions one at a time till I got the right one and then synced my home directory. At this point I was a little happier, but thinking that I would probably be without the iBook for a while I used tar and ftp to get a copy of my home directory over to the Solaris box so that I would at least have access to my stuff from work.

Next thing was to call technical support. I bought the machine over a year ago but had fortunately taken advice and splashed out on AppleCare. When I described the symptoms the support guy asked me to try resetting first the PMU and then the PRAM. To my great surprise and relief that seemed to do the trick, but he warned me that the problem might have been caused by a faulty logic board and I was given a case number to quote in the event of further problems.

My joy was short lived. As soon as I tried logging in the screen image started to break up with random horizontal lines appearing. Then the cursor stopped responding and I had to force another restart. This time I got a bit further and managed to log in before the screen went crazy again. I tried one last restart and it came back with a blank screen. At this point I gave up and Googled for "iBook logic board" which lead me to this description of the problem.

It seems that my iBook is one of the ones with a flaky logic board, and Apple is replacing them free of charge when they fail. I am now waiting for a box to arrive at my house, into which I will have to pack the iBook ready for it's journey to the European repair facility in Holland. This has been a frustrating and disruptive experience but it could have been much worse (having ssh enabled saved my skin!). Now I just have to trust that the machine will make it there and back without getting lost or damaged. It would be nice if Apple gave me some vouchers or something to compensate for the headache:-) Ian Gregory 2010